{"action":"Upgrade ruby-saml to 1.0.0-1 or later.","affected":[{"fixed":"1.0.0-1","introduced":"0"}],"component":"ruby-saml","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["1.0.0-1"],"id":"tcs_01M5NB530BY286VJDCWF514C6S","modified_at":"2026-09-09T07:00:36.773607820Z","published_at":"2023-05-27T19:15:09.043Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2015-20108","https://security-tracker.debian.org/tracker/CVE-2015-20108"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2015-20108","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2015-20108"}],"summary":"xml_security.rb in the ruby-saml gem before 1.0.0 for Ruby allows XPath injection and code execution because prepared statements are not used."}