{"action":"Upgrade glibc to 2.22-1 or later.","affected":[{"fixed":"2.22-1","introduced":"0"}],"component":"glibc","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2.22-1"],"id":"tcs_01M5NB53ACNE1F7HNXF8EB8B30","modified_at":"2026-09-09T07:00:36.101779603Z","published_at":"2023-06-25T17:15:14.187Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2015-20109","https://security-tracker.debian.org/tracker/CVE-2015-20109"],"severity":{"label":"medium","score":5.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2015-20109#Debian:14/glibc","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2015-20109"}],"summary":"end_pattern (called from internal_fnmatch) in the GNU C Library (aka glibc or libc6) before 2.22 might allow context-dependent attackers to cause a denial of service (application crash), as demonstrat"}