{"action":"Upgrade putty to 0.63-10 or later.","affected":[{"fixed":"0.63-10","introduced":"0"}],"component":"putty","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["0.63-10"],"id":"tcs_01M5NB58ZK5W1TSB1FVWQ67V5K","modified_at":"2026-09-09T06:47:31.128396314Z","published_at":"2015-03-27T14:59:05.697Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2015-2157","https://security-tracker.debian.org/tracker/CVE-2015-2157"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2015-2157#Debian:13/putty","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2015-2157"}],"summary":"The (1) ssh2_load_userkey and (2) ssh2_save_userkey functions in PuTTY 0.51 through 0.63 do not properly wipe SSH-2 private keys from memory, which allows local users to obtain sensitive information b"}