{"action":"Upgrade capnproto to 0.4.1-3 or later.","affected":[{"fixed":"0.4.1-3","introduced":"0"}],"component":"capnproto","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["0.4.1-3"],"id":"tcs_01M5NB5JCF3Q2PP8SKMTNBD2VM","modified_at":"2026-09-09T07:00:38.859475549Z","published_at":"2017-08-09T18:29:01.027Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2015-2311","https://security-tracker.debian.org/tracker/CVE-2015-2311"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2015-2311#Debian:14/capnproto","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2015-2311"}],"summary":"Integer underflow in Sandstorm Cap'n Proto before 0.4.1.1 and 0.5.x before 0.5.1.1 might allow remote peers to cause a denial of service or possibly obtain sensitive information from memory or execute"}