{"action":"Upgrade libzip to 0.11.2-1.2 or later.","affected":[{"fixed":"0.11.2-1.2","introduced":"0"}],"component":"libzip","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["0.11.2-1.2"],"id":"tcs_01M5NB5N70J889SYSMZX43VSDG","modified_at":"2026-09-09T06:47:29.390152813Z","published_at":"2015-03-30T10:59:12.727Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2015-2331","https://security-tracker.debian.org/tracker/CVE-2015-2331"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2015-2331#Debian:13/libzip","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2015-2331"}],"summary":"Integer overflow in the _zip_cdir_new function in zip_dirent.c in libzip 0.11.2 and earlier, as used in the ZIP extension in PHP before 5.4.39, 5.5.x before 5.5.23, and 5.6.x before 5.6.7 and other pr"}