{"action":"Upgrade openssl to 1.0.2e-1 or later.","affected":[{"fixed":"1.0.2e-1","introduced":"0"}],"component":"openssl","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["1.0.2e-1"],"id":"tcs_01M5NB6EM6FBPYXG7A1ZT2BEJM","modified_at":"2026-09-09T07:01:16.190774990Z","published_at":"2015-12-06T20:59:05.973Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2015-3195","https://security-tracker.debian.org/tracker/CVE-2015-3195"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2015-3195","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2015-3195"}],"summary":"The ASN1_TFLG_COMBINE implementation in crypto/asn1/tasn_dec.c in OpenSSL before 0.9.8zh, 1.0.0 before 1.0.0t, 1.0.1 before 1.0.1q, and 1.0.2 before 1.0.2e mishandles errors caused by malformed X509_A"}