{"action":"Upgrade openssl to 1.0.2d-1 or later.","affected":[{"fixed":"1.0.2d-1","introduced":"0"}],"component":"openssl","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["1.0.2d-1"],"id":"tcs_01M5NB6F0ZHWA7HQHGJXFSNNVC","modified_at":"2026-09-09T06:47:18.352509367Z","published_at":"2015-12-06T20:59:06.913Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2015-3196","https://security-tracker.debian.org/tracker/CVE-2015-3196"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2015-3196#Debian:14/openssl","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2015-3196"}],"summary":"ssl/s3_clnt.c in OpenSSL 1.0.0 before 1.0.0t, 1.0.1 before 1.0.1p, and 1.0.2 before 1.0.2d, when used for a multi-threaded client, writes the PSK identity hint to an incorrect data structure, which al"}