{"action":"Upgrade qemu to 1:2.4+dfsg-1a or later.","affected":[{"fixed":"1:2.4+dfsg-1a","introduced":"0"}],"component":"qemu","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["1:2.4+dfsg-1a"],"id":"tcs_01M5NB6HADPXNX0KWD4ED0BKEY","modified_at":"2026-09-09T06:47:27.933127611Z","published_at":"2015-08-31T10:59:07.580Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2015-3214","https://security-tracker.debian.org/tracker/CVE-2015-3214"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2015-3214","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2015-3214"}],"summary":"The pit_ioport_read in i8254.c in the Linux kernel before 2.6.33 and QEMU before 2.3.1 does not distinguish between read lengths and write lengths, which might allow guest OS users to execute arbitrar"}