{"action":"Upgrade sqlite3 to 3.8.9-1 or later.","affected":[{"fixed":"3.8.9-1","introduced":"0"}],"component":"sqlite3","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["3.8.9-1"],"id":"tcs_01M5NB7033EMPRB15ZS893M3N6","modified_at":"2026-09-09T06:47:31.768534772Z","published_at":"2015-04-24T17:59:02.363Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2015-3416","https://security-tracker.debian.org/tracker/CVE-2015-3416"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2015-3416#Debian:14/sqlite3","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2015-3416"}],"summary":"The sqlite3VXPrintf function in printf.c in SQLite before 3.8.9 does not properly handle precision and width values during floating-point conversions, which allows context-dependent attackers to cause"}