{"action":"Upgrade squid to 4.1-1 or later.","affected":[{"fixed":"4.1-1","introduced":"0"}],"component":"squid","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["4.1-1"],"id":"tcs_01M5NB730JQMJENRTPX6XK0TYQ","modified_at":"2026-09-09T06:47:25.580642237Z","published_at":"2015-05-18T15:59:11.650Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2015-3455","https://security-tracker.debian.org/tracker/CVE-2015-3455"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2015-3455#Debian:14/squid","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2015-3455"}],"summary":"Squid 3.2.x before 3.2.14, 3.3.x before 3.3.14, 3.4.x before 3.4.13, and 3.5.x before 3.5.4, when configured with client-first SSL-bump, do not properly validate the domain or hostname fields of X.509"}