{"action":"Upgrade squid to 4.8-r0 or later.","affected":[{"fixed":"4.8-r0","introduced":"3.3.9"}],"component":"squid","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.9","exploited":false,"fixed_versions":["4.8-r0"],"id":"tcs_01M5NB7J0K1RYQ62HW8AY2CRM9","modified_at":"2026-09-21T06:17:52.465552136Z","published_at":"2019-07-11T19:15:13Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2019-12525","https://security.alpinelinux.org/vuln/CVE-2019-12525"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2019-12525#Alpine:v3.9/squid","url":"https://osv.dev/vulnerability/ALPINE-CVE-2019-12525"}],"summary":"An issue was discovered in Squid 3.3.9 through 3.5.28 and 4.x through 4.7. When Squid is configured to use Digest authentication, it parses the header Proxy-Authorization. It searches for certain toke"}