{"action":"Upgrade squid to 3.5.27-r4 or later.","affected":[{"fixed":"3.5.27-r4","introduced":"0"}],"component":"squid","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.8","exploited":false,"fixed_versions":["3.5.27-r4"],"id":"tcs_01M5NB7MPYX9H8MAGB06XV12Z4","modified_at":"2026-09-21T06:17:52.466156845Z","published_at":"2020-02-04T21:15:10.807Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2019-12528","https://security.alpinelinux.org/vuln/CVE-2019-12528"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2019-12528#Alpine:v3.8/squid","url":"https://osv.dev/vulnerability/ALPINE-CVE-2019-12528"}],"summary":"An issue was discovered in Squid before 4.10. It allows a crafted FTP server to trigger disclosure of sensitive information from heap memory, such as information associated with other users' sessions"}