{"action":"Upgrade squid to 4.8-r0 or later.","affected":[{"fixed":"4.8-r0","introduced":"2.0"}],"component":"squid","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.9","exploited":false,"fixed_versions":["4.8-r0"],"id":"tcs_01M5NB7NBDKM94TPCKEHYCYJ51","modified_at":"2026-09-21T06:17:52.466083372Z","published_at":"2019-07-11T19:15:13.157Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2019-12529","https://security.alpinelinux.org/vuln/CVE-2019-12529"],"severity":{"label":"medium","score":5.9},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2019-12529#Alpine:v3.9/squid","url":"https://osv.dev/vulnerability/ALPINE-CVE-2019-12529"}],"summary":"An issue was discovered in Squid 2.x through 2.7.STABLE9, 3.x through 3.5.28, and 4.x through 4.7. When Squid is configured to use Basic Authentication, the Proxy-Authorization header is parsed via uu"}