{"action":"Upgrade ipython to 2.4.1-1 or later.","affected":[{"fixed":"2.4.1-1","introduced":"0"}],"component":"ipython","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["2.4.1-1"],"id":"tcs_01M5NB7X07KBZTQVDMBD3S42F1","modified_at":"2026-09-09T07:01:05.593092501Z","published_at":"2017-09-20T18:29:00.890Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2015-4707","https://security-tracker.debian.org/tracker/CVE-2015-4707"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2015-4707","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2015-4707"}],"summary":"Cross-site scripting (XSS) vulnerability in IPython before 3.2 allows remote attackers to inject arbitrary web script or HTML via vectors involving JSON error messages and the /api/notebooks path."}