{"action":"Upgrade znc to 1.7.1-r1 or later.","affected":[{"fixed":"1.7.1-r1","introduced":"0"}],"component":"znc","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.8","exploited":false,"fixed_versions":["1.7.1-r1"],"id":"tcs_01M5NB7XZBRM9Y6XP6HCKVQFS3","modified_at":"2026-09-21T06:17:52.467574971Z","published_at":"2019-06-15T16:29:00.210Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2019-12816","https://security.alpinelinux.org/vuln/CVE-2019-12816"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2019-12816#Alpine:v3.8/znc","url":"https://osv.dev/vulnerability/ALPINE-CVE-2019-12816"}],"summary":"Modules.cpp in ZNC before 1.7.4-rc1 allows remote authenticated non-admin users to escalate privileges and execute arbitrary code by loading a module with a crafted name."}