{"action":"Upgrade swift to 2.4.0-1 or later.","affected":[{"fixed":"2.4.0-1","introduced":"0"}],"component":"swift","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2.4.0-1"],"id":"tcs_01M5NB873B8RXGGCXHJ95B78P6","modified_at":"2026-09-09T06:47:22.348582899Z","published_at":"2015-10-26T17:59:05.483Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2015-5223","https://security-tracker.debian.org/tracker/CVE-2015-5223"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2015-5223#Debian:14/swift","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2015-5223"}],"summary":"OpenStack Object Storage (Swift) before 2.4.0 allows attackers to obtain sensitive information via a PUT tempurl and a DLO object manifest that references an object in another container."}