{"action":"Upgrade glibc to 2.21-1 or later.","affected":[{"fixed":"2.21-1","introduced":"0"}],"component":"glibc","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["2.21-1"],"id":"tcs_01M5NB8CWM2JEHGED7QWE0YBYM","modified_at":"2026-09-09T06:47:18.839617932Z","published_at":"2015-12-17T19:59:02.573Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2015-5277","https://security-tracker.debian.org/tracker/CVE-2015-5277"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2015-5277","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2015-5277"}],"summary":"The get_contents function in nss_files/files-XXX.c in the Name Service Switch (NSS) in GNU C Library (aka glibc or libc6) before 2.20 might allow local users to cause a denial of service (heap corrupt"}