{"action":"Upgrade putty to 0.66-1 or later.","affected":[{"fixed":"0.66-1","introduced":"0"}],"component":"putty","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["0.66-1"],"id":"tcs_01M5NB8GDB5XA7CJ0HXMDMY3F9","modified_at":"2026-09-09T06:47:25.388073753Z","published_at":"2015-12-07T20:59:08.060Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2015-5309","https://security-tracker.debian.org/tracker/CVE-2015-5309"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2015-5309#Debian:14/putty","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2015-5309"}],"summary":"Integer overflow in the terminal emulator in PuTTY before 0.66 allows remote attackers to cause a denial of service (memory corruption) or possibly execute arbitrary code via an ECH (erase characters)"}