{"action":"Upgrade wpa to 2.3-2.3 or later.","affected":[{"fixed":"2.3-2.3","introduced":"0"}],"component":"wpa","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2.3-2.3"],"id":"tcs_01M5NB8HWRQM4JXAR7R7N3XYS3","modified_at":"2026-09-09T07:01:03.240854152Z","published_at":"2018-02-21T16:29:00.287Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2015-5314","https://security-tracker.debian.org/tracker/CVE-2015-5314"],"severity":{"label":"medium","score":5.9},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2015-5314#Debian:14/wpa","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2015-5314"}],"summary":"The eap_pwd_process function in eap_server/eap_server_pwd.c in hostapd 2.x before 2.6 does not validate that the reassembly buffer is large enough for the final fragment when used with (1) an internal"}