{"action":"Upgrade rails to 2:4.2.5.1-1 or later.","affected":[{"fixed":"2:4.2.5.1-1","introduced":"0"}],"component":"rails","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["2:4.2.5.1-1"],"id":"tcs_01M5NB9V2SP503DNWB9K60H0TZ","modified_at":"2026-09-09T07:01:50.361174671Z","published_at":"2016-02-16T02:59:04.877Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2015-7581","https://security-tracker.debian.org/tracker/CVE-2015-7581"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2015-7581","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2015-7581"}],"summary":"actionpack/lib/action_dispatch/routing/route_set.rb in Action Pack in Ruby on Rails 4.x before 4.2.5.1 and 5.x before 5.0.0.beta1.1 allows remote attackers to cause a denial of service (superfluous ca"}