{"action":"Upgrade bouncycastle to 1.51-1 or later.","affected":[{"fixed":"1.51-1","introduced":"0"}],"component":"bouncycastle","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["1.51-1"],"id":"tcs_01M5NBA5K3J6G5WDSY2FZDX68R","modified_at":"2026-09-09T06:47:20.020750946Z","published_at":"2015-11-09T16:59:09.277Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2015-7940","https://security-tracker.debian.org/tracker/CVE-2015-7940"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2015-7940#Debian:14/bouncycastle","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2015-7940"}],"summary":"The Bouncy Castle Java library before 1.51 does not validate a point is withing the elliptic curve, which makes it easier for remote attackers to obtain private keys via a series of crafted elliptic c"}