{"action":"Upgrade patch to 2.7.6-r4 or later.","affected":[{"fixed":"2.7.6-r4","introduced":"0"}],"component":"patch","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.8","exploited":false,"fixed_versions":["2.7.6-r4"],"id":"tcs_01M5NBARXN0V84RZBYV16RM92N","modified_at":"2026-09-21T06:17:52.482440306Z","published_at":"2019-07-26T13:15:12.783Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2019-13638","https://security.alpinelinux.org/vuln/CVE-2019-13638"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2019-13638#Alpine:v3.8/patch","url":"https://osv.dev/vulnerability/ALPINE-CVE-2019-13638"}],"summary":"GNU patch through 2.7.6 is vulnerable to OS shell command injection that can be exploited by opening a crafted patch file that contains an ed style diff payload with shell metacharacters. The ed edito"}