{"action":"Upgrade ghostscript to 9.27-r3 or later.","affected":[{"fixed":"9.27-r3","introduced":"9.00"}],"component":"ghostscript","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.21","exploited":false,"fixed_versions":["9.27-r3"],"id":"tcs_01M5NBBHDCY6VYVXTZ6XCSVE6D","modified_at":"2026-09-21T06:17:52.485371098Z","published_at":"2019-11-27T14:15:11.220Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2019-14812","https://security.alpinelinux.org/vuln/CVE-2019-14812"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2019-14812#Alpine:v3.21/ghostscript","url":"https://osv.dev/vulnerability/ALPINE-CVE-2019-14812"}],"summary":"A flaw was found in all ghostscript versions 9.x before 9.50, in the .setuserparams2 procedure where it did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions."}