{"action":"Upgrade node-serve-index to 1.9.1-1 or later.","affected":[{"fixed":"1.9.1-1","introduced":"0"}],"component":"node-serve-index","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["1.9.1-1"],"id":"tcs_01M5NBC6Q4P8TJN68RSCM9ZKDE","modified_at":"2026-09-09T07:01:45.602811898Z","published_at":"2017-01-23T21:59:00.563Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2015-8856","https://security-tracker.debian.org/tracker/CVE-2015-8856"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2015-8856","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2015-8856"}],"summary":"Cross-site scripting (XSS) vulnerability in the serve-index package before 1.6.3 for Node.js allows remote attackers to inject arbitrary web script or HTML via a crafted file or directory name."}