{"action":"Upgrade uglifyjs to 2.7.4-1 or later.","affected":[{"fixed":"2.7.4-1","introduced":"0"}],"component":"uglifyjs","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["2.7.4-1"],"id":"tcs_01M5NBC6YNVXWWS0QZ4GCT044E","modified_at":"2026-09-09T07:01:46.490039316Z","published_at":"2017-01-23T21:59:00.580Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2015-8857","https://security-tracker.debian.org/tracker/CVE-2015-8857"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2015-8857","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2015-8857"}],"summary":"The uglify-js package before 2.4.24 for Node.js does not properly account for non-boolean values when rewriting boolean expressions, which might allow attackers to bypass security mechanisms or possib"}