{"action":"Upgrade glibc to 2.21-1 or later.","affected":[{"fixed":"2.21-1","introduced":"0"}],"component":"glibc","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["2.21-1"],"id":"tcs_01M5NBCTBR9TH19861ZDBMPCV8","modified_at":"2026-09-09T07:02:09.354013561Z","published_at":"2017-03-20T16:59:01.500Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2015-8984","https://security-tracker.debian.org/tracker/CVE-2015-8984"],"severity":{"label":"medium","score":5.9},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2015-8984","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2015-8984"}],"summary":"The fnmatch function in the GNU C Library (aka glibc or libc6) before 2.22 might allow context-dependent attackers to cause a denial of service (application crash) via a malformed pattern, which trigg"}