{"action":"Upgrade libssh to 0.6.3-4.3 or later.","affected":[{"fixed":"0.6.3-4.3","introduced":"0"}],"component":"libssh","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["0.6.3-4.3"],"id":"tcs_01M5NBD71QECHRVDHJE8EC6PCS","modified_at":"2026-09-22T07:00:07.169845333Z","published_at":"2016-04-13T17:59:08.413Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2016-0739","https://security-tracker.debian.org/tracker/CVE-2016-0739"],"severity":{"label":"medium","score":5.9},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2016-0739#Debian:14/libssh","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2016-0739"}],"summary":"libssh before 0.7.3 improperly truncates ephemeral secrets generated for the (1) diffie-hellman-group1 and (2) diffie-hellman-group14 key exchange methods to 128 bits, which makes it easier for man-in"}