{"action":"Upgrade bouncycastle to 1.56-1 or later.","affected":[{"fixed":"1.56-1","introduced":"0"}],"component":"bouncycastle","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["1.56-1"],"id":"tcs_01M5NBDK7427GBC5W6FPG2RBWZ","modified_at":"2026-09-22T07:00:13.745719955Z","published_at":"2018-06-01T20:29:00.217Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2016-1000338","https://security-tracker.debian.org/tracker/CVE-2016-1000338"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2016-1000338","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2016-1000338"}],"summary":"In Bouncy Castle JCE Provider version 1.55 and earlier the DSA does not fully validate ASN.1 encoding of signature on verification. It is possible to inject extra elements in the sequence making up th"}