{"action":"Upgrade bouncycastle to 1.56-1 or later.","affected":[{"fixed":"1.56-1","introduced":"0"}],"component":"bouncycastle","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["1.56-1"],"id":"tcs_01M5NBDM828H75DN2EVWFHXCBA","modified_at":"2026-09-22T07:00:13.955639791Z","published_at":"2018-06-04T13:29:00.387Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2016-1000342","https://security-tracker.debian.org/tracker/CVE-2016-1000342"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2016-1000342","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2016-1000342"}],"summary":"In the Bouncy Castle JCE Provider version 1.55 and earlier ECDSA does not fully validate ASN.1 encoding of signature on verification. It is possible to inject extra elements in the sequence making up"}