{"action":"Upgrade bouncycastle to 1.56-1 or later.","affected":[{"fixed":"1.56-1","introduced":"0"}],"component":"bouncycastle","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["1.56-1"],"id":"tcs_01M5NBDN798FJ6RMR7Y94VM332","modified_at":"2026-09-22T07:00:08.922575328Z","published_at":"2018-06-04T21:29:00.303Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2016-1000346","https://security-tracker.debian.org/tracker/CVE-2016-1000346"],"severity":{"label":"low","score":3.7},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2016-1000346","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2016-1000346"}],"summary":"In the Bouncy Castle JCE Provider version 1.55 and earlier the other party DH public key is not fully validated. This can cause issues as invalid keys can be used to reveal details about the other par"}