{"action":"Upgrade redis to 3:3.2.7-1 or later.","affected":[{"fixed":"3:3.2.7-1","introduced":"0"}],"component":"redis","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["3:3.2.7-1"],"id":"tcs_01M5NBEZ48TM01APA0Y0ZQ2J6Z","modified_at":"2026-09-22T07:01:21.124903025Z","published_at":"2017-10-24T18:29:00.197Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2016-10517","https://security-tracker.debian.org/tracker/CVE-2016-10517"],"severity":{"label":"high","score":7.4},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2016-10517#Debian:14/redis","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2016-10517"}],"summary":"networking.c in Redis before 3.2.7 allows \"Cross Protocol Scripting\" because it lacks a check for POST and Host: strings, which are not valid in the Redis protocol (but commonly occur when an attack t"}