{"action":"Upgrade lz4 to 1.9.1-r1 or later.","affected":[{"fixed":"1.9.1-r1","introduced":"0"}],"component":"lz4","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.10","exploited":false,"fixed_versions":["1.9.1-r1"],"id":"tcs_01M5NBGRPS5HSZD01H4S0JM425","modified_at":"2026-09-21T06:17:52.499982689Z","published_at":"2019-10-14T02:15:10.873Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2019-17543","https://security.alpinelinux.org/vuln/CVE-2019-17543"],"severity":{"label":"high","score":8.1},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2019-17543","url":"https://osv.dev/vulnerability/ALPINE-CVE-2019-17543"}],"summary":"LZ4 before 1.9.2 has a heap-based buffer overflow in LZ4_write32 (related to LZ4_compress_destSize), affecting applications that call LZ4_compress_fast with a large input. (This issue can also lead to"}