{"action":"Upgrade openssl to 1.0.2i-1 or later.","affected":[{"fixed":"1.0.2i-1","introduced":"0"}],"component":"openssl","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["1.0.2i-1"],"id":"tcs_01M5NBGRX6DBZVZX4CFWRQAP48","modified_at":"2026-09-22T07:00:40.201843374Z","published_at":"2016-06-20T01:59:02.087Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2016-2177","https://security-tracker.debian.org/tracker/CVE-2016-2177"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2016-2177","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2016-2177"}],"summary":"OpenSSL through 1.0.2h incorrectly uses pointer arithmetic for heap-buffer boundary checks, which might allow remote attackers to cause a denial of service (integer overflow and application crash) or"}