{"action":"Upgrade git to 1:2.7.0-1 or later.","affected":[{"fixed":"1:2.7.0-1","introduced":"0"}],"component":"git","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["1:2.7.0-1"],"id":"tcs_01M5NBH0X2AT67W3B6TR97M6RG","modified_at":"2026-09-22T07:00:42.221544535Z","published_at":"2016-04-08T14:59:01.187Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2016-2315","https://security-tracker.debian.org/tracker/CVE-2016-2315"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2016-2315#Debian:13/git","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2016-2315"}],"summary":"revision.c in git before 2.7.4 uses an incorrect integer data type, which allows remote attackers to execute arbitrary code via a (1) long filename or (2) many nested trees, leading to a heap-based bu"}