{"action":"Upgrade virglrenderer to 0.8.1-r0 or later.","affected":[{"fixed":"0.8.1-r0","introduced":"0"}],"component":"virglrenderer","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.11","exploited":false,"fixed_versions":["0.8.1-r0"],"id":"tcs_01M5NBHMZVBBM7ZR62G1X5G44F","modified_at":"2026-09-21T06:17:52.502295834Z","published_at":"2019-12-23T16:15:11.243Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2019-18390","https://security.alpinelinux.org/vuln/CVE-2019-18390"],"severity":{"label":"high","score":7.1},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2019-18390","url":"https://osv.dev/vulnerability/ALPINE-CVE-2019-18390"}],"summary":"An out-of-bounds read in the vrend_blit_need_swizzle function in vrend_renderer.c in virglrenderer through 0.8.0 allows guest OS users to cause a denial of service via VIRGL_CCMD_BLIT commands."}