{"action":"Upgrade mcollective to 2.12.0+dfsg-1 or later.","affected":[{"fixed":"2.12.0+dfsg-1","introduced":"0"}],"component":"mcollective","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["2.12.0+dfsg-1"],"id":"tcs_01M5NBHNAVPM01CDP8GG79AW57","modified_at":"2026-09-22T07:01:30.374702633Z","published_at":"2017-02-13T18:59:00.457Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2016-2788","https://security-tracker.debian.org/tracker/CVE-2016-2788"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2016-2788","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2016-2788"}],"summary":"MCollective 2.7.0 and 2.8.x before 2.8.9, as used in Puppet Enterprise, allows remote attackers to execute arbitrary code via vectors related to the mco ping command."}