{"action":"Upgrade fribidi to 1.0.7-r1 or later.","affected":[{"fixed":"1.0.7-r1","introduced":"1.0.0"}],"component":"fribidi","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.19","exploited":false,"fixed_versions":["1.0.7-r1"],"id":"tcs_01M5NBHQMWTHVF4952YBKZ2C2R","modified_at":"2026-09-21T06:17:52.502657490Z","published_at":"2019-11-13T14:15:10.287Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2019-18397","https://security.alpinelinux.org/vuln/CVE-2019-18397"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2019-18397#Alpine:v3.19/fribidi","url":"https://osv.dev/vulnerability/ALPINE-CVE-2019-18397"}],"summary":"A buffer overflow in the fribidi_get_par_embedding_levels_ex() function in lib/fribidi-bidi.c of GNU FriBidi through 1.0.7 allows an attacker to cause a denial of service or possibly execute arbitrary"}