{"action":"Upgrade firefox-esr to 45.2.0esr-1 or later.","affected":[{"fixed":"45.2.0esr-1","introduced":"0"}],"component":"firefox-esr","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["45.2.0esr-1"],"id":"tcs_01M5NBHY6YRN3HW6Z73JK2ZSF3","modified_at":"2026-09-22T07:03:05.840875229Z","published_at":"2016-06-13T10:59:04.370Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2016-2821","https://security-tracker.debian.org/tracker/CVE-2016-2821"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2016-2821#Debian:14/firefox-esr","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2016-2821"}],"summary":"Use-after-free vulnerability in the mozilla::dom::Element class in Mozilla Firefox before 47.0 and Firefox ESR 45.x before 45.2, when contenteditable mode is enabled, allows remote attackers to execut"}