{"action":"Upgrade mercurial to 3.7.3-1 or later.","affected":[{"fixed":"3.7.3-1","introduced":"0"}],"component":"mercurial","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["3.7.3-1"],"id":"tcs_01M5NBJHBQDV7QAEXHFV2CBTE0","modified_at":"2026-09-22T07:00:45.235196516Z","published_at":"2016-04-13T16:59:20.850Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2016-3630","https://security-tracker.debian.org/tracker/CVE-2016-3630"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2016-3630#Debian:14/mercurial","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2016-3630"}],"summary":"The binary delta decoder in Mercurial before 3.7.3 allows remote attackers to execute arbitrary code via a (1) clone, (2) push, or (3) pull command, related to (a) a list sizing rounding error and (b)"}