{"action":"Upgrade optipng to 0.7.6-1 or later.","affected":[{"fixed":"0.7.6-1","introduced":"0"}],"component":"optipng","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["0.7.6-1"],"id":"tcs_01M5NBJXZ18EFPCETEQ3RK9APW","modified_at":"2026-09-22T07:01:59.206064653Z","published_at":"2016-04-13T16:59:23.100Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2016-3981","https://security-tracker.debian.org/tracker/CVE-2016-3981"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2016-3981#Debian:13/optipng","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2016-3981"}],"summary":"Heap-based buffer overflow in the bmp_read_rows function in pngxrbmp.c in OptiPNG before 0.7.6 allows remote attackers to cause a denial of service (out-of-bounds read or write access and crash) or po"}