{"action":"Upgrade pgpdump to 0.31-0.1 or later.","affected":[{"fixed":"0.31-0.1","introduced":"0"}],"component":"pgpdump","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["0.31-0.1"],"id":"tcs_01M5NBK1TS2710KQBH44M42MP8","modified_at":"2026-09-22T07:00:48.367615502Z","published_at":"2016-05-26T14:59:01.167Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2016-4021","https://security-tracker.debian.org/tracker/CVE-2016-4021"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2016-4021#Debian:13/pgpdump","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2016-4021"}],"summary":"The read_binary function in buffer.c in pgpdump before 0.30 allows context-dependent attackers to cause a denial of service (infinite loop and CPU consumption) via crafted input, as demonstrated by th"}