{"action":"Upgrade squid to 4.1-1 or later.","affected":[{"fixed":"4.1-1","introduced":"0"}],"component":"squid","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["4.1-1"],"id":"tcs_01M5NBK310PRBNXRWZ7QRSBB40","modified_at":"2026-09-22T07:03:06.482337876Z","published_at":"2016-04-25T14:59:02.267Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2016-4051","https://security-tracker.debian.org/tracker/CVE-2016-4051"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2016-4051","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2016-4051"}],"summary":"Buffer overflow in cachemgr.cgi in Squid 2.x, 3.x before 3.5.17, and 4.x before 4.0.9 might allow remote attackers to cause a denial of service or execute arbitrary code by seeding manager reports wit"}