{"action":"Upgrade xen to 4.10.4-r2 or later.","affected":[{"fixed":"4.10.4-r2","introduced":"0"}],"component":"xen","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.8","exploited":false,"fixed_versions":["4.10.4-r2"],"id":"tcs_01M5NBK9S66CWQ8RTW55SD8RGM","modified_at":"2026-09-21T06:17:52.508583925Z","published_at":"2019-12-11T18:16:19.270Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2019-19577","https://security.alpinelinux.org/vuln/CVE-2019-19577"],"severity":{"label":"high","score":7.2},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2019-19577#Alpine:v3.8/xen","url":"https://osv.dev/vulnerability/ALPINE-CVE-2019-19577"}],"summary":"An issue was discovered in Xen through 4.12.x allowing x86 AMD HVM guest OS users to cause a denial of service or possibly gain privileges by triggering data-structure access during pagetable-height u"}