{"action":"Upgrade wpa to 2.3-2.4 or later.","affected":[{"fixed":"2.3-2.4","introduced":"0"}],"component":"wpa","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["2.3-2.4"],"id":"tcs_01M5NBKKEMJ159E5G6FJB662NY","modified_at":"2026-09-22T07:01:04.384278603Z","published_at":"2016-05-09T10:59:42.987Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2016-4477","https://security-tracker.debian.org/tracker/CVE-2016-4477"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2016-4477#Debian:13/wpa","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2016-4477"}],"summary":"wpa_supplicant 0.4.0 through 2.5 does not reject \\n and \\r characters in passphrase parameters, which allows local users to trigger arbitrary library loading and consequently gain privileges, or cause"}