{"action":"Upgrade netty to 1:4.0.37-1 or later.","affected":[{"fixed":"1:4.0.37-1","introduced":"0"}],"component":"netty","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["1:4.0.37-1"],"id":"tcs_01M5NBM6ZMA81G32AAEYJS51TS","modified_at":"2026-09-22T07:01:55.148488485Z","published_at":"2017-04-13T14:59:01.823Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2016-4970","https://security-tracker.debian.org/tracker/CVE-2016-4970"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2016-4970","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2016-4970"}],"summary":"handler/ssl/OpenSslEngine.java in Netty 4.0.x before 4.0.37.Final and 4.1.x before 4.1.1.Final allows remote attackers to cause a denial of service (infinite loop)."}