{"action":"Upgrade nginx to 1.16.1-r6 or later.","affected":[{"fixed":"1.16.1-r6","introduced":"0"}],"component":"nginx","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.24","exploited":false,"fixed_versions":["1.16.1-r6"],"id":"tcs_01M5NBMA5PARHZDDSPGW4PZ8M4","modified_at":"2026-09-21T06:17:52.511243261Z","published_at":"2020-01-09T21:15:12.027Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2019-20372","https://security.alpinelinux.org/vuln/CVE-2019-20372"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2019-20372#Alpine:v3.24/nginx","url":"https://osv.dev/vulnerability/ALPINE-CVE-2019-20372"}],"summary":"NGINX before 1.17.7, with certain error_page configurations, allows HTTP request smuggling, as demonstrated by the ability of an attacker to read unauthorized web pages in environments where NGINX is"}