{"action":"Upgrade librsvg to 2.40.21-r0 or later.","affected":[{"introduced":"2.42.0"}],"component":"librsvg","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.9","exploited":false,"fixed_versions":["2.40.21-r0"],"id":"tcs_01M5NBMDBFPKCYSRM9YT148KX6","modified_at":"2026-09-21T06:17:52.511443541Z","published_at":"2020-02-02T14:15:10.523Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2019-20446","https://security.alpinelinux.org/vuln/CVE-2019-20446"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2019-20446#Alpine:v3.9/librsvg","url":"https://osv.dev/vulnerability/ALPINE-CVE-2019-20446"}],"summary":"In xml.rs in GNOME librsvg before 2.46.2, a crafted SVG file with nested patterns can cause denial of service when passed to the library for processing. The attacker constructs pattern elements so tha"}