{"action":"Upgrade puppet to 4.7.0-1 or later.","affected":[{"fixed":"4.7.0-1","introduced":"0"}],"component":"puppet","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:11","exploited":false,"fixed_versions":["4.7.0-1"],"id":"tcs_01M5NBNEKD0DWKJ4A2MHYY2K2C","modified_at":"2026-08-04T06:04:07.676101400Z","published_at":"2017-12-06T15:29:00.217Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2016-5713","https://security-tracker.debian.org/tracker/CVE-2016-5713"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2016-5713","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2016-5713"}],"summary":"Versions of Puppet Agent prior to 1.6.0 included a version of the Puppet Execution Protocol (PXP) agent that passed environment variables through to Puppet runs. This could allow unauthorized code to"}