{"action":"Upgrade rails to 2:4.2.7.1-1 or later.","affected":[{"fixed":"2:4.2.7.1-1","introduced":"0"}],"component":"rails","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2:4.2.7.1-1"],"id":"tcs_01M5NBP4JFF3R3GHDRR0W4WSYH","modified_at":"2026-09-22T07:02:09.898007037Z","published_at":"2016-09-07T19:28:10.067Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2016-6316","https://security-tracker.debian.org/tracker/CVE-2016-6316"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2016-6316#Debian:14/rails","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2016-6316"}],"summary":"Cross-site scripting (XSS) vulnerability in Action View in Ruby on Rails 3.x before 3.2.22.3, 4.x before 4.2.7.1, and 5.x before 5.0.0.1 might allow remote attackers to inject arbitrary web script or"}