{"action":"Upgrade curl to 7.51.0-1 or later.","affected":[{"fixed":"7.51.0-1","introduced":"0"}],"component":"curl","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["7.51.0-1"],"id":"tcs_01M5NBQCE9MD1V1FTMK4QBSTMZ","modified_at":"2026-09-22T07:03:11.224407601Z","published_at":"2016-10-07T14:59:08.100Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2016-7167","https://security-tracker.debian.org/tracker/CVE-2016-7167"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2016-7167","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2016-7167"}],"summary":"Multiple integer overflows in the (1) curl_escape, (2) curl_easy_escape, (3) curl_unescape, and (4) curl_easy_unescape functions in libcurl before 7.50.3 allow attackers to have unspecified impact via"}